当 Windows 10 LTSC 遭遇 Windows Terminal ,留给我们的仅仅只有遗憾吗?

众所周知 Linux 下有各种各样、丰富多彩的终端程序,可以随时随地任意地让我们把玩。

在帝王制度早已终结百年有余的现代,今天喜欢玩这款,明天厌了换那款,这成功地让玩家有了后宫佳丽三千的感觉。

然而,一向不太注重终端程序的 Windows 终于也放出了全新的 Windows Terminal

这款新式的终端程序样式美观、功能强大,作为后宫之主...咳咳...那个系统玩家,一直想着啥时候也能领略一下她的风采。

我的系统正是传说中的长期支持版 Windows 10 LTSC ,它能否配得上拥有 Windows Terminal 呢?

我的地盘我做主,不折腾一下怎么知道呢,干就是了嘛!


早就听说 Windows Terminal 是经由应用商店下载安装的,于是打开应用商店,搜索到 Windows Terminal 时却发现了诡异的一幕。


瞧见没有,图中右上角的安装按钮是灰色的,而左上角却堂而皇之地告诉你,你已拥有此应用?

我兴冲冲地在开始程序菜单中找了有5分钟,愣是没找到,这是闹哪样?

往下滚动商店窗口,发现安装要求居然不满足。


最低安装要求操作系统的版本必须等于或高于 18362.0 ,也就是 1903

我检查了一下我的 LTSC ,它是 1809 的,如果我的小学数学没学错的话,好像是低了一点哈。

这可怎么办呢?


我这个人的最大缺点就是不服输啊!

于是我就在网上找啊找,居然找到了 TerminalGitHub 上项目的链接。

链接:https://github.com/microsoft/Terminal

嘿嘿,没想到吧,介绍页面上还有很多另类的 Terminal 安装方法,果然没来错,原来不止应用商店这一种方法啊!

既然来 GitHub ,那么就先试试这里的标准官方方法吧。

插句话,手动安装方法并不支持自动升级,想升级还是得再次手动安装新发布的版本。

好了,找到发布页面 Releases Page ,选择最新版本 Lastest Release ,在最下方点击下载 msixbundle 文件。

Microsoft.WindowsTerminal_1.4.3141.0_8wekyb3d8bbwe.msixbundle

备用下载链接:https://www.90pan.com/b2162083 密码:35n7


官网下载太慢,建议用我的备用下载。

好不容易下载好后,把文件放到一个单独的文件夹内。

打开 PowerShell 输入命令开始安装。

PS C:\> Add-AppxPackage .\Microsoft.WindowsTerminal_1.4.3141.0_8wekyb3d8bbwe.msixbundle
 

系统立马给出了部署失败的提示。


提示很明显,还是因为没有满足最低系统安装条件。

但是我还是没有放弃,说过了,爱折腾是我的最大缺点,这点小失败并没有能阻挡住我。

于是,接着死磕......


GitHub 上继续找,发现可以通过巧克力 Chocolatey 来安装 Terminal

巧克力是啥,简单的来说,是在 Windows 上统一安装和管理软件用的管理程序。

有点类似 Linux 上的PKG管理器,不过我用的也不是很多,有兴趣的小伙伴儿们可以自行查阅。

既然巧克力可以用来安装 Termianl ,那么就废话少说,直接动手吧。

按照官网说明,很简单地安装好了巧克力。

检查巧克力版本无误后,输入以下命令开始安装 Terminal

choco install microsoft-windows-terminal
 


嘿,巧克力正在下载所需的更新程序和 Terminal 主程序,看来有门啊!

漫长的等待,居然等来的是超时,下载失败。


看着希望的曙光就要来到,我似乎一下子着了魔,疯狂地重新输入命令,再来!


似乎这次比较顺利,已经出现了交互提示,我果断按下了 y 继续安装。

人的命运总是这么飘忽不定,下载成功可安装却问题频频。

虽然安装进程一直在进行中,可有几个更新程序似乎无法成功安装在 LTSC 版本的系统上。


看到了开头,结尾多半也就能猜得出来了。

最最关键主要的 microsoft-windows-terminal 仍然没有安装成功,原因依然是版本过低。


有句老话叫,不撞南墙不回头。

其实我是戴着头盔撞的,我自己不疼,只是心疼头盔。

明知不可为而为之,只是单纯折腾折腾、自我娱乐一下吗?


LTSC 也就是长期支持版,是微软为了方便一些企业从 Win7 过渡到 Win10 时,保证其系统的平稳迁移而专为用户开发的稳定版本。

很多用户特别是企业用户虽得益于此,但事物总有两面性,LTSC 并不支持诸如 Microsoft EdgeMicrosoft Store 等等很多功能。

这不支持那也不支持,越来越多的“缺陷”使得用户对其开始了抱怨。

就像前文所述,目前的长期支持版并不能安装 Microsoft Terminal

这么好看又好用的终端程序却不能安装使用,难道仅仅只是令人遗憾之事吗?

最近微软也在大力推广自家的 Edge 浏览器,甚至达到了强制用户升级的地步。

小伙伴儿们,如果你也在使用 LTSC ,你会为了安装 Microsoft Terminal 而考虑和它说再见吗?

欢迎在留言区说说你的看法哦!


WeChat@网管小贾 | www.sysadm.cc



评论  
+1 #1 naj@qq.com 2021-02-03 22:01
google 到的官方解释,就是不要想了,不可能的!

Sorry. Right now, there's two big blockers to adoption on 1809.

XAML islands was a technology preview and didn't support high-DPI, DPI changes, or accessibility in 1809. We rely on them heavily.
1903 added support for side-by-side WinRT component activation, something deep in the COM stack that lets us find our DLLs when they're right next to our EXE.
引用
提交评论

安全码
刷新

© 2020-present 网管小贾 | 微信公众号 @网管小贾
许可协议:CC-BY-NC 4.0 | 转载文章请注明作者出处及相关链接